On 17/07/2023 07:11, Chaitanya S Prakash wrote:
+TEST(test_purecap_map_growsdown) +{
- purecap_map_growsdown();
I don't think there's much point in having every testcase call its own separate helper and do nothing else. I see that the two existing testcases are written like that, I'm not sure why. I'd favour removing the indirection in the existing testcases (separate patch), and writing the new test code directly in the testcase functions.
Something else that would be nice to change in the existing code and the new tests is the use of "addr" to name pointer variables. Unfortunately it is very common in the kernel and the "official" prototypes for mmap syscalls, but it should be avoided for new code, especially when manipulating both addresses and pointers.
Kevin